一、概要
近日,基调听云关注到Apache Druid存在任意文件读取漏洞(CVE-2021-36749)。由于没有对用户可控的 HTTP InputSource 做限制,允许通过身份验证的用户从指定数据源读取数据。又因Apache Druid本身默认情况下就缺乏授权认证,故攻击者可以构造恶意请求,在未授权的情况下利用该漏洞读取系统任意文件,导致服务器敏感信息泄露。
Apache Druid是一款开源分布式的支持实时分析的数据存储系统。华为云提醒使用Apache Druid的用户及时安排自检并做好安全加固。
二、威胁级别
威胁级别:【严重】
三、CVSS评分
CVE-2021-36749 9.8(AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
四、漏洞影响范围
影响版本:
Apache Druid < 0.22.0
安全版本:
Apache Druid >= 0.22.0
五、漏洞排查及处置
目前,基调听云已发布新补丁修复了该漏洞,请受影响的用户联系相应的技术支持升级到安全版本。
  • 继续阅读
  • 继续阅读
  • 继续阅读
  • 继续阅读